开发者社区> 问答> 正文

以特定格式输出两个数的和

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

展开
收起
a123456678 2016-03-23 16:22:34 1857 0
1 条回答
写回答
取消 提交回答
  • #include<stdio.h>
    #include<string.h>
    int main()
    {
        char a[1000],b[1000],c[1001];
        int i,j=1,p=0,n,n1,n2;
        scanf("%d",&n);
      while(n--)
        {
            scanf("%s %s",a,b);
            printf("Case %d:\n",j);
            printf("%s + %s = ",a,b);
            n1=strlen(a)-1;
            n2=strlen(b)-1;
            for(i=0;n1>=0||n2>=0;i++,n1--,n2--)
            {
                if(n1>=0&&n2>=0){c[i]=a[n1]+b[n2]-'0'+p;}
                if(n1>=0&&n2<0){c[i]=a[n1]+p;}
                if(n1<0&&n2>=0){c[i]=b[n2]+p;}
                p=0;
                if(c[i]>'9'){c[i]=c[i]-10;p=1;}
            }
            if(p==1)  printf("%d",p);
            while(i--)
                printf("%c",c[i]);
            j++;
            if(n!=1) printf("\n\n");
            else printf("\n");
        }
    }
    2019-07-17 19:11:28
    赞同 展开评论 打赏
问答地址:
问答排行榜
最热
最新

相关电子书

更多
低代码开发师(初级)实战教程 立即下载
冬季实战营第三期:MySQL数据库进阶实战 立即下载
阿里巴巴DevOps 最佳实践手册 立即下载