畅通工程,How Many Tables ACM第九天-图论

简介: 下面两题的方法是一样的都是并查集的应用; 并查集的重点就是找到祖先节点的过程。 重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); } 不断地递归,递归到找到自己是自己的祖先为止。
下面两题的方法是一样的都是并查集的应用;
并查集的重点就是找到祖先节点的过程。
重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); }
不断地递归,递归到找到自己是自己的祖先为止。并且把它取接到那个祖先节点上;这样可以节省空间和时间。

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15414    Accepted Submission(s): 7560


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
 
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
 
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy
 


#include <cstdio>
#define maxn 1005
using namespace std;
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d %d",&n,&m);
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - ans;
		printf("%d\n",answer);
	}
	return	0;
}

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32971    Accepted Submission(s): 17391


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

Sample Input
 
     
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
 
     
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 

Source
 

Recommend
JGShining
 

 
 
#include <cstdio>
#include <cstring>

using namespace std;
#define maxn 1005
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m) && n){
		memset(p,0,sizeof(p));
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - 1 - ans;
		printf("%d\n",answer);
	}
	return	0;
}


相关文章
|
8月前
2022天梯赛三月冲刺——PAT (Advanced Level)1013 Battle Over Cities (并查集找连通块)
2022天梯赛三月冲刺——PAT (Advanced Level)1013 Battle Over Cities (并查集找连通块)
49 0
|
10月前
|
存储 人工智能 测试技术
第十四届蓝桥杯省赛JavaB组试题E【蜗牛】Dijkstra堆优化 or 线性DP?
第十四届蓝桥杯省赛JavaB组试题E【蜗牛】Dijkstra堆优化 or 线性DP?
第十四届蓝桥杯省赛JavaB组试题E【蜗牛】Dijkstra堆优化 or 线性DP?
2021年度训练联盟热身训练赛第一场——Early Orders(单调栈)
2021年度训练联盟热身训练赛第一场——Early Orders(单调栈)
44 0
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
74 0
|
机器学习/深度学习 Go
[计蒜客] ACM-ICPC 2019 南京赛区网络预赛 | 部分题解 | 线段树 + 线性筛 + 最短路(下)
J. Nanjing Sum 题目描述 输入 输出 样例输入 样例输出 提示 L. Magical Girl Haze 题目描述 输入 输出 样例输入 样例输出 题意:
117 0
[计蒜客] ACM-ICPC 2019 南京赛区网络预赛 | 部分题解 | 线段树 + 线性筛 + 最短路(下)
|
人工智能 BI 网络架构
[计蒜客] ACM-ICPC 2018 南京赛区网络预赛 | 部分题解 | 线段树 + 线性筛 + 最短路(上)
E. AC Challenge 题目描述 输入 输出 样例输入 样例输出 提示 题意: A. An Olympian Math Problem G. Lpl and Energy-saving Lamps 题目描述 输入 输出 样例输入 样例输出 提示 ac_code:
136 0
[计蒜客] ACM-ICPC 2018 南京赛区网络预赛 | 部分题解 | 线段树 + 线性筛 + 最短路(上)
|
机器学习/深度学习
[Nowcoder | UPC] 2021年度训练联盟热身训练赛第六场 Hopscotch | 最短路 bfs
题目描述 There’s a new art installation in town, and it inspires you… to play a childish game. The art installation consists of a floor with an n×n matrix of square tiles. Each tile holds a single number from 1 to k. You want to play hopscotch on it.
93 0
2019牛客暑期多校2-Partition problem深搜
题意: 将2*n个人分成两部分,每部分都有n个人 而且每个人只能属于一个组,问按照给出的算式得到的竞争力最大值是多少
76 0
2019牛客暑期多校2-Partition problem深搜
|
人工智能 Java BI
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem D. Team Name
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem D. Team Name
106 0
|
Java
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem H. Dominoes
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem H. Dominoes
104 0